Zum Hauptinhalt springen
Version: 2.1

Navigation

Prism's user interface is organised into three main sections:

Prism File Menu Open Recent

In this section it is possible to navigate the application menu, see the Project name, minimize, maximize or close the user interface.

Clicking on Prism logo will hide all View Tabs, showing the selected Surface in fullscreen.

File​

Prism File Menu

ItemDescription
New ProjectResets application state and starts a new project.
SaveSaves the current project.
Save AsSaves a new / replace project file.
OpenOpens a project file.
Open RecentOpens a project from a list of previous projects, sorted by the most recent.
Collect All and SaveSaves the current project and collects all media files in use to a folder.
Open Project with CollectionOpens a project file and loads all media files saved with it.

More information found at Projects Management

ItemDescription
ImportImports either a Bank, Encode List or Regions.
ExportExports either a Bank, Encode List or Regions.

More information found at Import/Export

ItemDescription
SettingsNavigates to the Settings View.

Edit​

Prism Edit Menu

ItemDescription
UndoUndo the last action. Note: Not all features have Undo actions.
RedoRedo the previous action. Note: Not all features have Redo actions.

View​

Prism Header Video Menu

ItemDescription
PreviewOpen the Preview window for editing bank elements.

Audio​

Prism Audio Menu

ItemDescription
Audio DeviceSets the audio device output for Prism. This can also be configured via Settings.

Video​

Prism Header Video Menu

ItemDescription
Show GridDisplays a reference grid over the media player / layer preview.
Transparency PreviewToggles on the alpha channel, showing a checkerboard in transparent areas.

Help​

Prism Header Help Menu

ItemDescription
ManualOpens the Desktop Manual app.
SupportShows a pop-up with company details.
AboutShows a pop-up with information about Prism.

View Tabs​

Prism File Menu Open Recent

In this section it is possible to navigate the following app Views:

An underline will give visual feedback of the selected View.

Status Bar​

This bar shows the following app informations at a glance.

Prism Status Bar Left

  • App performance metrics - The full performance metrics are shown in the System Info page in Settings.
  • Prism release version.
  • User interface connection status indicator - red when disconnected, green when connected to the Server.

Multi Selection​

It is possible to select multiple elements by:

  • Ticking element selection boxes.
  • Holding Ctrl button and clicking on elements.
  • Clicking on an element then Shift clicking another element to range select.
  • Pressing Ctrl-A to select all elements in a list.

When multiple Bank Elements, Layers (in Play View), Regions or Encode List entries have been selected, a Multiple elements selected orange label is shown in the Controls panel and changes will be applied to every selected element.

Any unchanged values in the Controls panel will initially display those of the first selected element.

If Undo and Redo are permitted, all selected elements will be affected.